POJ 2337 Catenyms(欧拉路径)

题意:在play on words的基础上增加了按字典序打印字符串。

解题思路:判断是否存在欧拉路径的方式和play on words 的方式一样。判断出度和入度即可,关键是如何按字典序输出欧拉路径,字典序可以先对输入的串进行排序,排序之后倒着输入进去, 最后输出再倒着输出就行了。


问题描述

A catenym is a pair of words separated by a period such that the last letter of the first word is the same as the last letter of the second. For example, the following are catenyms: 
dog.gopher 
gopher.rat
rat.tiger
aloha.aloha
arachnid.dog

A compound catenym is a sequence of three or more words separated by periods such that each adjacent pair of words forms a catenym. For example, 

aloha.aloha.arachnid.dog.gopher.rat.tiger 

Given a dictionary of lower case words, you are to find a compound catenym that contains each of the words exactly once.

输入

The first line of standard input contains t, the number of test cases. Each test case begins with 3 <= n <= 1000 - the number of words in the dictionary. n distinct dictionary words follow; each word is a string of between 1 and 20 lowercase letters on a line by itself.

输出

For each test case, output a line giving the lexicographically least compound catenym that contains each dictionary word exactly once. Output "***" if there is no solution.

样例输入

2
6
aloha
arachnid
dog
gopher
rat
tiger
3
oak
maple
elm

样例输出

aloha.arachnid.dog.gopher.rat.tiger
***


Memory: 836 KB Time: 47 MS
Language: G++ Result: Accepted


#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

#define MAX_N 1005
const int INF = 0x3f3f3f3f;
int head[30];
int top = 0;
struct node
{
    int to, next;
    int id;
}edge[MAX_N];
int vis[MAX_N];
int ans[MAX_N];
int indegree[30];
int outdegree[30];
int iq = 0;
string str[MAX_N];

inline void init()
{
    memset(head, -1, sizeof(head));
    memset(ans, 0, sizeof(ans));
    memset(vis, 0 ,sizeof(vis));
    memset(indegree, 0, sizeof(indegree));
    memset(outdegree, 0, sizeof(outdegree));
    top = 0;
    iq = 0;
}

void add_edge(int u, int v, int id)
{
    edge[top].to = v;
    edge[top].next = head[u];
    edge[top].id = id;
    head[u] = top++;
}

void dfs(int now)
{
    for(int k = head[now] ; k != -1 ; k = edge[k].next)
    {
        if(!vis[k])
        {
            vis[k] = 1;
            dfs(edge[k].to);
            ans[iq++] = edge[k].id;
        }
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        init();
        int n;
        scanf("%d", &n);
        for(int i = 0 ; i < n ; i++)
        {
            cin>>str[i];
        }
        sort(str, str + n);
        int start = INF;
        for(int i = n - 1 ; i >= 0 ;i--)
        {
            int len = str[i].length();
            int a = str[i][0] - 'a';
            int b = str[i][len - 1] - 'a';
            add_edge(a, b, i);
            outdegree[a]++;
            indegree[b]++;
            start = min(a, b);
        }
        int in = 0 ;
        int out = 0;
        int flag = 0;
//        int start = 0;
        for(int i = 0  ; i < 30  ; i++)
        {
            if(indegree[i] != outdegree[i])
            {
                if(indegree[i] - outdegree[i] == 1)
                {
                    if(in)
                    {
                        flag = 1;
                        break;
                    }
                    in = 1;
                }
                else if(outdegree[i] - indegree[i] == 1)
                {
                    if(out)
                    {
                        flag =1;
                        break;
                    }
                    out = 1;
                    start = i;
                }
                else
                {
                    flag =1;
                    break;
                }
            }
        }
        if(flag)
        {
            printf("***\n");
            continue;
        }
        dfs(start);
        if(iq != n)
        {
            printf("***\n");
        }
        else
        {
            for(int i = iq -1 ; i >= 0 ; i--)
            {
                cout<<str[ans[i]];
                if(i != 0) cout<<".";
                else cout<<endl;
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值