问题:
输入整数n(3<=n<=7),编写程序输出1,2,…,n整数的全排列,按字典序输出。
输入格式:
一行输入正整数n。
输出格式:
按字典序输出1到n的全排列。每种排列占一行,数字间无空格。
输入样例:
在这里给出一组输入。例如:
3
输出样例:
在这里给出相应的输出。例如:
123
132
213
231
312
321
解决方案:
主要是next_permutation()函数的运用,使用该函数会使得该题简单许多。
源代码如下:
#include<stdint.h>
#include<iostream>
#include<algorithm>
#include <vector>
using namespace std;
int main() {
int n,temp;
std::vector<int>arr;
cin >> n;
if (n < 3 || n>7) {
cout << "输入整数n(3<=n<=7)" << endl;
return 0;
}
for (int i = 0; i < n; i++)
{
temp = i + 1;
arr.push_back(temp);
}
do
{
for (auto first = arr.begin(), end = arr.end(); first != end; ++first) {
cout << *first;
}
cout << endl;
} while (next_permutation(arr.begin(),arr.end()));
}