Catch That Cow

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Example Input
5 17
Example Output
4
Hint
poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Author
#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
const int maxn = 1e5 + 1;
int graph[maxn];
bool visited[maxn];
void BFS(ll N, ll K) {
    queue<int> Q;
    visited[N] = 1;
    graph[N] = 0;
    Q.push(N);
    while(!Q.empty()) {
        int p = Q.front();
        if(p == K) {
            printf("%d\n", graph[p]);
            return;
        }
        Q.pop();
        int q;
        for(int i = 0; i < 3; i++) {
            if(i == 0) {
                q = p + 1;
            } else if(i == 1) {
                q = p - 1;
            } else {
                q = p * 2;
            }
            if(q < 0 || q > 1e5) {
                continue;
            }
            if(!visited[q]) {
                visited[q] = 1;
                graph[q] = graph[p] + 1;
                Q.push(q);
            }

        }
    }
}
int main() {
    ll N, K;
    while(~scanf("%lld%lld", &N, &K)) {
        if(K <= N) {
            printf("%lld\n", N - K);
        } else {
            memset(visited, 0, sizeof(visited));
            BFS(N, K);
        }
    }
    return 0;
}


/***************************************************
User name:
Result: Accepted
Take time: 0ms
Take Memory: 504KB
Submit time: 2018-01-30 15:15:04
****************************************************/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值