A - 费马小定理

求:3^0 + 3^1 +...+ 3^(N) mod 1000000007

Input

输入一个数N(0 <= N <= 10^9)

Output

输出:计算结果

Sample Input

3

Sample Output

40
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <cstring>

using namespace std;
typedef long long ll;
const int maxn = 1e2 + 5;
const int INF = (1 << 30);
const double inf = 1e-6;
const int mod = 1e9 + 7;
const int MOD = 1e9 + 7;
int t, n, m, ans, cnt, cc;
int f[maxn], vis[maxn][maxn];
char mp[maxn][maxn];
struct node {
    int x, y, steps;
} no[maxn];
ll FastPow(ll n, ll k) {
    ll ans = 1;
    while(k) {
        if(k & 1) {
            ans *= n;
            ans %= mod;
        }
        k >>= 1;
        n *= n;
        n %= mod;
    }
    return ans;
}
int main() {
    scanf("%d", &n);
    ll a = (FastPow(3, n + 1) - 1 + mod) % mod;
    ll b = (FastPow(2, mod - 2)) % mod;
    printf("%lld\n", (a * b) % mod);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值