安装tensorflow报ImportError: libcublas.so.9.0: cannot open shared object file的解决方法(2018年4月)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qysh123/article/details/79977891

话说,tensorflow,cudnn这些东西,就不能打个对应版本的包发布么,每次让人因为版本的问题折腾,浪费生命。

今天在一台重新安装系统的ubuntu上安装tensorflow+keras,就按照我在几个月之前的一篇博客来做的,结果到了import tensorflow这一步,就报错了:

ImportError: libcublas.so.9.0: cannot open shared object file: No such file or directory

感觉就是版本问题惹的祸,搜索了一下,大家的解决方法也都大同小异(例如下面几篇博客:https://blog.csdn.net/w5688414/article/details/79187499https://blog.csdn.net/twt520ly/article/details/79415787),或者使用高版本的CUDA+cudnn,或者降低tensorflow的版本,具体而言,CUDA和cudnn这两者的对应关系如下(按照这篇博客的介绍https://blog.csdn.net/gsch_12/article/details/79368990):

CUDA 8.0→cuDNN v5.1 / CUDA 8.0→cuDNN v6.0 / CUDA 9.0→cuDNN v7.0.5

另外,tensorflow 1.6/1.5和CUDA 9.0对应,1.4/1.3和CUDA 8.0对应

由于最新版的cudnn需要注册并做问卷调查,我实在懒得弄,所以准备降低tensorflow的版本,不过运行了好几次:

pip install tensorflow-gpu==1.4

还是报一样的错,想了想,是不是该先删掉原来的tensorflow版本:

sudo pip uninstall tensorflow-gpu

删除了之后再重新运行第一条命令,结果在python中报错:

No module named tensorflow

真是太奇怪了!无奈之下,只能运行:

sudo pip install -U --pre tensorflow-gpu==1.4
然后就不报标题中的错了,真的很奇怪,看来还是pip的命令有些细节我不太理解。
阅读更多

没有更多推荐了,返回首页