PAT甲级.1002. A+B for Polynomials (25)

1002. A+B for Polynomials (25)


题目:

This time, you are supposed to find A+B where A and B are two polynomials.

输入格式:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

输出格式:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

输入样例:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

输出样例:

3 2 1.5 1 2.9 0 3.2

PAT链接


思路:

  1. 开一个double类型的数组a[i]用来表示exponent为i时候的系数,初值为0。cnt记录数组中非零的个数。
  2. 按格式读入第一个多项式,再读入第二个多项式,并把对应系数直接加到第一个多项式式上。
  3. 用MAX存最大的指数,避免每次都遍历整个数组(其实效果有限)
  4. 计算非零系数项的个数cnt并输出,按格式输出多项式。

代码:

/*
* @tag     PAT_A_1002
* @authors R11happy (xushuai100@126.com)
* @date    2016-07-20 16:08:16-16:59:04
* @version 1.0
* @Language C++
* @Ranking  105/4548
*/

#include <cstdio>
#include <cstring>
#include <cmath>
#include <stack>
using namespace std;

double a[1005]; //a[i]用来存指数为i的系数
int main()
{
    int k;
    int expo;
    stack<int> st;
    int Max = 0;    //记录出现过的最大指数
    int cnt = 0;    //记录输出的多项式项数
    double coef;
    scanf("%d", &k);
    while (k--) //输入第一个多项式
    {
        scanf("%d", &expo);
        if (expo > Max)
            Max = expo;
        scanf("%lf", &a[expo]);
    }
    scanf("%d", &k);
    while (k--) //输入第二个多项式
    {
        scanf("%d", &expo);
        if (expo > Max)
            Max = expo;
        scanf("%lf", &coef);
        a[expo] += coef;
    }
    for (int i = 0; i <= Max; i++)
    {
        if (a[i])
        {
            st.push(i); //对所有非零项,push指数
            cnt++;
        }
    }
    printf("%d", cnt);  //最初为printf("%d ", cnt); 但当只输出0时末尾有多余空格
    for (int i = 0; i<cnt; i++)
    {
        int index = st.top();   //记录栈顶元素,即结果项的指数
        printf(" %d %.1f", index, a[index]);
        st.pop();   //堆栈的使用要记得pop栈顶
    }
    printf("\n");
    return 0;
}






收获:

  1. 强行使用stack,其实也可以从MAX开始降序遍历,可以省去stack。
  2. 注意系数用double类型,换为int会意外跳出
  3. 注意只输出系数非0的项,最后一个测试点结果就是输出0,但要注意结尾不能有多余空格。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值