【描述】
在一个字符串中找出元音字母a、e、i、o、u出现的次数。
【输入】
输入一行字符串(字符串中可能有空格)。字符串长度小于80个字符。
【输出】
输出一行,依次输出a、e、i、o、u在输入字符串中出现的次数,整数以空格间隔。
【输入示例】
If so, youalready have a Google Account. You can sign in on the right.
【输出示例】
5 4 3 7 3
【提示】
注意:只统计小写元音字母a、e、i、o、u出现的次数。
【C代码】
---------------
#include<stdio.h>
#include<ctype.h>
#include<string.h>
#defineSTRING_SIZE 80
intmain(void) {
int count[5] = {0};
char str[STRING_SIZE];
int i;
gets(str);
for(i = 0; i < strlen(str); ++i) {
if(islower(str[i])) {
switch(str[i]) {
case 'a':
count[0]++;
break;
case 'e':
count[1]++;
break;
case 'i':
count[2]++;
break;
case 'o':
count[3]++;
break;
case 'u':
count[4]++;
break;
}
}
}
printf("%d %d %d %d %d\n",count[0], count[1], count[2], count[3], count[4]);
return 0;
}