Poj2155 Matrix 树状数组

题目描述:

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 26468 Accepted: 9778

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

思路:

因为是改变一个矩阵求点,可以联想到树状数组的该段求点的算法。

只用加一层循环,相当于横着竖着都是一个一维树状数组。


关于add函数:


改变矩阵(x1,x2,y1,y2)所需的操作就是add(x1,y1,1),add(x1,y2+1,-1),add(x2+1,y1,-1),add(x2+1,y2+1,1)。


代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

int n,m;
int a[1010][1010]= {0};

int lowbit(int x) {
	return x&(-x);
}

void add(int x,int y,int z) {
	for(int i=x; i<=n; i+=lowbit(i))
		for(int j=y; j<=n; j+=lowbit(j))
			a[i][j]+=z;
}

int getsum(int x,int y) {
	int s=0;
	for(int i=x; i>0; i-=lowbit(i)) {
		for(int j=y; j>0; j-=lowbit(j)) {
			s+=a[i][j];
		}
	}
	return s;
}
 
int main() {

	int t;
	scanf("%d",&t);
	while(t--) {
		memset(a,0,sizeof(a));
		scanf("%d%d",&n,&m);
		for(int i=1; i<=m; i++) {
			char ask;
			scanf("%*c%c",&ask);
			if(ask=='C') {
				int x1,y1,x2,y2;
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				add(x1,y1,1),add(x1,y2+1,-1),add(x2+1,y1,-1),add(x2+1,y2+1,1);
			}
			if(ask=='Q') {
				int x,y;
				scanf("%d%d",&x,&y);
				printf("%d\n",getsum(x,y)%2);
			}
		}
		printf("\n");
	}

	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值