POJ3104 烘衣服 二分

题目:

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2
/*首先应该想到二分枚举答案。枚举一个mid时,若一件衣服的水量大于mid
,则一件衣服的最短时间是烘干一段时间,再自己蒸发一段时间,为(num[i]-mid)/(k-1)
这样把所有衣服的时间加起来,判断可行即可
首先对a数组进行排序由于最长时间为max(a),最短时间为1,那我假设需要的时间为mid=(max+1)/2,
那么对于含水量小于Mid的衣服就让他自然风干(不一定是最优解,但先假设是这样),
然后对含水量大于mid的衣服挨个使用吹风机,直到每件衣服的含水量小于Mid为止,
若这些时间加起来小于mid,那么说明在mid的时间内还可以用吹风机吹更多的衣服,
*/
#include <cmath>
#include <cstdio>
#include <iostream>
using namespace std;
long long a[100005];
long long n,k;
long long judge(long long t){           //t是用了多长时间,因为不用烘干机时每分钟也会掉一单位水
    long long i,sum;                    //所以a[i]<=t时,不用考虑这类的衣服它自己也会干,因而问
    sum=0;                              //题变为总共用了多长时间的烘干机,假设用了x单位的烘干机
    for(i=0;i<n;i++)                    //因此k*x+(t-x)>=a[i],推出x>=(a[i]-t)/(k-1),从而求出使
    if(a[i]>t)                          //用烘干机的总时间
    sum+=(long long)(ceil((a[i]-t)*1.0/(k-1)));
    return sum;
}
int main(){
    long long i,l,r,ans,mid;
    while(scanf("%I64d",&n)!=EOF){
        l=r=ans=0;
        for(i=0;i<n;i++){
        scanf("%I64d",&a[i]);
        r=max(a[i],r);
        }
        scanf("%I64d",&k);
        if(k==1){                       //k==1时相当于烘干机没有用,所以输出
            printf("%I64d\n",r);        //最大时间即可
            continue;
        }
        while(l<=r){                    //二分时间
            mid=(l+r)/2;
            if(judge(mid)<=mid){
                ans=mid;
                r=mid-1;
            }
            else
            l=mid+1;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


 

  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值