题目:
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
//题意:从n到k,每一步有+1,-1,*2 这三种运算方式,求解从n到k的所需要的最小的步数
//方法:广搜
#include<iostream>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAX=100010;
int step[MAX],vis[MAX];
int n,k;
int bfs()
{
int t,next;
queue<int>q;
q.push(n);
step[n]=0;
while(!q.empty())
{
t=q.front();
q.pop();
for(int i=1;i<=3;i++)
{
if(i==1)next=t+1;
if(i==2)next=t-1;
else if(i==3)next=t*2;
if(next<0||next>MAX)continue;//此处注意
if(!vis[next])
{
vis[next]=1;
q.push(next);
step[next]=step[t]+1;
}
if(next==k)return step[k];
}
}
}
int main()
{
memset(vis,0,sizeof(vis));
cin>>n>>k;
if(n>=k)cout<<n-k<<endl;
else cout<<bfs()<<endl;
return 0;
}