UVA 12034 Race

9 篇文章 0 订阅

Race

Disky and Sooma, two of the biggest mega minds of Bangladesh went to a far country. They ate, coded and wandered around, even in their holidays. They passed several months in this way. But everything has an end. A holy person, Munsiji came into their life. Munsiji took them to derby (horse racing). Munsiji enjoyed the race, but as usual Disky and Sooma did their as usual task instead of passing some romantic moments. They were thinking- in how many ways a race can finish! Who knows, maybe this is their romance!

In a race there are n horses. You have to output the number of ways the race can finish. Note that, more than one horse may get the same position. For example, 2 horses can finish in 3 ways.

1. Both first

2. horse1 first and horse2 second

3. horse2 first and horse1 second

Input 

Input starts with an integer T ( 1000), denoting the number of test cases. Each case starts with a line containing an integer n ( 1n1000).

Output 

For each case, print the case number and the number of ways the race can finish. The result can be very large, print the result modulo 10056.

Sample Input 

3

1

2

3

Sample Output 

Case 1: 1

Case 2: 3

Case 3: 13

 

题意:问n匹马赛跑,一共有多少结局。

两匹马有三种结局

1.      Both first

2.      horse1 first and horse2 second

3.      horse2 first and horse1 second

 

#include<stdio.h>

#include<cstring>

int modulo=10056;

int s[1010][1010];

int p[1010];

int main()

{

int t,n;

scanf("%d",&t);

int q=1;

int sum;

n=1000;

memset(s,0,sizeof s);

s[1][1]=1;

for(int i=2;i<=n;i++)

{

for(int j=1;j<=i;j++)

{

s[i][j]+=(s[i-1][j]*j+s[i-1][j-1]*j)%modulo;

}

}

 

for(int i=1;i<=n;i++)

{

sum=0;

for(int j=1;j<=i;j++)

{

sum=(sum+s[i][j])%modulo;

}

p[i]=sum;

}

while(t--)

{

scanf("%d",&n);

printf("Case %d: %d\n",q++,p[n]);

}

return 0;

}

 

 

 

MOD运算

mod运算,即求余运算,是在整数运算中求一个整数x除以另一个整数y的余数的运算,且不考虑运算的商。

在计算机程序设计中都有MOD运算,它的含义是 取得两个整数相除后结果的余数。

如:7 mod 3 = 1

因为7 除以 3 商2余1,余数1即MOD运算后的结果。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值