poj1026-Cipher

Cipher

Description
Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

Input
The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separbated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.
Output
Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.
Sample Input
10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0
Sample Output
BolHeol b
C RCE

题意
给出n个乱序数组,按照给出的顺序给字符串排序k次。

题解
按照题目说的一步一步做就可以了,但是k可能过大,所以找到循环周期,即每个字符在所给顺序下变换回原来的字符的最小次数,用xh[]记录。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
int a[203], xh[203] ,an[203];
char ans[203], A[203];
int N, k;
void solve() {//记录循环的周期
    for(int i = 1; i <= N; i++) {
        int cnt = 1;
        int pos = i;
        while(a[pos] != i) {//变换
            pos = a[pos];
            cnt++;
        }
        xh[i] = cnt;
    }
}
int main() {
    while(scanf("%d", &N) != EOF) {
        if(N == 0) break;
        memset(a, 0, sizeof(a));
        for(int i = 1; i <= N; i++) {
            scanf("%d", &a[i]);
        }
        solve();
        while(scanf("%d", &k) != EOF) {
            if(k == 0) break;
            getchar();//用scanf(" ")会错
            gets(A + 1);
            int len = strlen(A + 1);
            for(int i = len + 1; i <= N; i++) {
                A[i] = ' ';
            }
            ans[N + 1] = '\0';
            for(int i = 1; i <= N; i++) {
                int temp = k % xh[i];
                int pos = i;
                while(temp--) {
                    pos = a[pos];
                }
                ans[pos] = A[i];
            }
            for(int i = 1; i <= N; i++) {
                printf("%c", ans[i]);
            }
            printf("\n");
        }
        printf("\n");
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值