G - Median POJ - 3579(二分)

G - Median POJ - 3579

Given N numbers, X1, X2, … , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!
Note in this problem, the median is defined as the (m/2)-th smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, … , XN, ( Xi ≤ 1,000,000,000 3 ≤ N ≤ 1,00,000 )
Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

题意
求数列1 ~ N 的任意两个差的绝对值的 第中间个 的值

题解

1 ~ N 的任意两个差 有k = (N - 1) * N / 2 个数字 所以不可能暴力。
所以用二分求 第 (k + 1) / 2个。

check 函数 判断 差小于 mid 的个数 是否小于 k 个。

#include <iostream>
#include <cmath>
#include <algorithm>
#include <string>
#include <cstdio>
#include <set>
#include <iomanip>
#include <vector>
using namespace std;
int const MAX = 1e5 +7;
long long N;
int k;
long long x[MAX];
bool check (int mid) {
    int sum = 0;
    for(int i = 0; i < N; i++) {
        int cnt = upper_bound(x, x + N, x[i] + mid) - x;
        sum += (cnt - i - 1);
    }
    if(sum >= k) return 1;
    return 0;
}
int main() {
    while(scanf("%lld", &N) != EOF) {
        for(int i = 0; i < N; i++) {
            scanf("%lld", &x[i]);
        }
        k = (N - 1) * N / 2;
        k = (k + 1) / 2 ;
        sort(x, x + N);
        int L = 0, R = x[N - 1] - x[0];
        while(R - L > 1) {
            int mid = (L + R) / 2;
            if(check(mid)) R = mid;
            else L = mid;
        }
        printf("%d\n", R);
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值