动态规划

1010.Number Triangles
Time Limit : 1000 MS         Memory Limit : 65536 K
Total Submissions : 849 (377 users)         Accepted : 490 (361 users)
[ My Solution ]

 

Description

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

 

 

Input

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

 

Output

A single line containing the largest sum using the traversal specified.

 

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

 

Sample Output

30

 


//Number Triangles
#include<stdio.h>
#include<stdlib.h>
#define MAX 1002
/*
int max(int *a,int *b)
{
  if(*a>*b)
    return *a;
  else return *b;
}
*/
void input()
{
  int a[MAX][MAX];


  freopen("1010.in","r",stdin);
  int n;
  scanf("%d",&n);


  for(int i=1;i<=n;i++)
    {
    for(int j=1;j<=i;j++)
      {
      scanf("%d",&a[i][j]);
      //      printf("%d ",a[i][j]);
      }
    //    printf("/n");
    }
  //    printf("/n");
  int temp;
  for(int i=n-1;i>0;i--)
    {
    for(int j=1;j<=i;j++)
      {

    a[i][j]+=(a[i+1][j]>a[i+1][j+1])?a[i+1][j]:a[i+1][j+1];
      }
    //  printf("/n");
    }
  printf("%d/n",a[1][1]);
}
int main()
{
  input();
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值