Longest Repeated Sequence

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

You are given a sequence of integers, A = a1, a2, ... an. A consecutive subsequence of A (say ai, ai+1 ... aj) is called a "repeated sequence" if it appears more than once in A (there exists some positive k that ai+k= ai, ai+k+1 = ai+1, ... aj+k = aj) and its appearances are not intersected (i + k > j).

Can you find the longest repeated sequence in A?

输入

Line 1: n (1 <= n <= 300), the length of A.
Line 2: the sequence, a1 a2 ... an (0 <= ai <= 100).

输出

The length of the longest repeated sequence.

样例输入
5
2 3 2 3 2
样例输出
2

未测试,要注意的是search参数为4个迭代器,而end迭代器要指向范围的下一个元素,故搜索范围为A.begin() + i, A.begin() + i + k+1。

循环条件为i+k<n,条件太弱。

当剩余搜索的序列长度小于要搜索的子序列长度则已不成立,即:

(i+k)-i<=n-(i+k+1)

i+2k+1<=n

#include <iostream>
#include <map>
#include <vector>
#include <string>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;

int main()
{
	int n;
	cin >> n;
	vector<int> A(n);
	for (size_t i = 0; i != n; ++i)
		cin >> A[i];
	int len=0, k=0;
	for (size_t i = 0; i != n; ++i)
	{
		//while (i + k < n)
		while (i+2*k+1<=n)
		{
			//   beg                           end          beg             end!! need + 1
			if (search(A.begin() + i + k + 1, A.end(), A.begin() + i, A.begin() + i + k+1) != A.end())
			{
				len = max(k+1, len);
				++k;
			}
			else
				break;
		}
		k = 0;
	}
	cout << len << endl;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值