C/C++训练1---最大公约数与最小公倍数

Problem Description
输入两个整数,求它们的最大公约数与最小公倍数。
Input
输入两个整数,两个整数之间用空格分开。
Output
第一行输出最大公约数;
第二行输出最小公倍数。
Example Input
64 48
Example Output
16
192
Hint

Author
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		int n = in.nextInt();
		int m =in.nextInt();
	 Compute gg = new Compute(n,m);
	 gg.show();
	}

}
 class Compute{
	 
	 int n;
	 int m;
	 public Compute(int n,int m){
		 this.n = n;
	     this.m = m;
	 }
	public void show(){
		 if(m<n)  
		    { 
			 int t;
		        t=m;  
		        m=n;  
		        n=t;  
		    }  
		    int m1=m;  
		    int n1=n;  
		int r;
		while(n!=0){
			r = m % n;
			m = n;
			n = r;
		}
		System.out.println(m+"\n"+m1*n1/m);
	}
	 
 }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值