PAT-Java-1009-Product of Polynomials (25)

1009. Product of Polynomials (25)

题目阐述

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6


题目分析

这道题和之前的多项式相加形式是一样的,只需要先用hashmap把多项式A的指数做key,系数作为value存起来,接下来对B中的每一项取出来分别和A式的每一项相乘,结果的放入一个新的hashmap中,如果同指数已经存在,则系数相加即可。总的时间复杂度是O(N*M),需要注意的是输出结果里必须按照降幂的形式打印,附上代码如下;

package PAT;

import java.util.ArrayList;
import java.util.Collections;
import java.util.HashMap;
import java.util.List;
import java.util.Map;
import java.util.Scanner;
import java.util.Set;

public class Main {

    public static void main(String[] args) {
        Scanner s = new Scanner(System.in);
        Map<Integer, Double> map = new HashMap<>();
        Map<Integer, Double> product = new HashMap<>();
        int n = s.nextInt();
        int[] arr = new int[n];
        for(int i=0; i<n; i++) {
            int u = s.nextInt();
            arr[i] = u;
            double v = s.nextDouble();
            map.put(u, v);
        }

        int m = s.nextInt();
        for(int i=0; i<m; i++) {
            int u = s.nextInt();
            double v = s.nextDouble();
            for(int j=0; j<n; j++) {
                int p = arr[j] + u;
                double q = map.get(arr[j]) * v;
                if(product.containsKey(p)) {
                    double temp = product.get(p);
                    temp += q;
                    if(Math.abs(temp) < 0.00001) product.remove(p);
                    else {
                        temp = Math.round(temp * 10)/ 10.0;
                        product.put(p, temp);
                    }
                } else
                    product.put(p, Math.round(q * 10) / 10.0);
            }
        }
        List<Integer> list = new ArrayList<>();
        Set<Integer> set = product.keySet();
        for(int i : set)
            list.add(i);
        Collections.sort(list);
        Collections.reverse(list);  
        System.out.print(product.size());
        for(int i : list)
            System.out.print(" " + i + " " + product.get(i));

    }

}

思考

这里降幂输出时候,取出的keyset是一个集合,得先对所有key实现排序,然后逐个输出,这里其实可以用java8里的流来把代码写的简洁点,但是我刷题的PAT里的编译器是javac1.6,所以还是老老实实使用工具类把。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值