PAT-Java-1007. Maximum Subsequence Sum (25)

1007. Maximum Subsequence Sum (25)

题目阐述

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4


题目分析

这是一道非常非常经典动态规划问题,最大子数组问题,求数组中连续子数组的最大和,求和值以及下标的起始两个位置,并不复杂。

附上代码如下:

import java.util.Scanner;

public class Main {

  public static void main(String[] args) {
    Scanner s = new Scanner(System.in);
    int n = s.nextInt();
    int[] arr = new int[n];
    for(int i=0; i<n; i++)
      arr[i] = s.nextInt();

    int left = 0, right = 0, temp = 0;
    int local = arr[0], total = arr[0];
    for(int i=1; i<n; i++) {
      if(arr[i] > arr[i] + local) {
        local = arr[i];
        temp = i;
      } else
        local = local + arr[i];
      if(local > total) {
        total = local;
        left = temp;
        right = i;
      }
    }
    boolean flag = true;
    for(int i=left; i<=right; i++)
      if(arr[i] >= 0) flag = false;
    if(flag) {
      total = 0;
      left = 0;
      right = n - 1;
    }
    System.out.println(total + " " + arr[left] + " " + arr[right]);
  }

}

总结
  • 一定看清题目啊,虽然这道题的思路非常简单,但是还是交了几次才AC,数次漏看题目中的关键信息,如输出的到底是什么,是下标还是元素,如果都为负怎么办,注意是负,那么有0也不行,将以上条件都注意到了就很快能AC了。

实际上,这种局部+全局的思想应用的非常广泛,如果将这道题改一下,求拥有乘积的最大子数组,又该如何计算呢?其实思路也是一样的,只不过得多设置一个最小值。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值