并查集的删除

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

scanf scanf scanf 以后都用scanf了

开两倍的数组,用n以后的数组成员来记录敌对关系,如果a和b+n是一伙的那么他俩就是敌对的,same函数用要有所体现 

#include<iostream>
using namespace std;
const int maxn = 200010; //开两倍 
int pre[maxn];
int n,m;
int Find(int x)
{
    if(pre[x]==x)
        return pre[x];
    else
        return pre[x]=Find(pre[x]);
} 
void merge(int x, int y)
{
   	int fx = Find(x);
	int fy = Find(y);
	if(fx != fy)
		pre[fx] = fy;
}
int same(int x, int y) 
{  
      if(Find(x)==Find(y))
          return 1;//相同 
      else if(Find(x)==Find(y+n))
          return 0;//不同 
      else
          return 2;//不确定 
}  
int main(){
	int t;
	scanf("%d",&t);
	char c;
	int a,b;
	while(t--){
		scanf("%d%d",&n,&m);
		for(int i=1;i<=2*n;i++){
			pre[i]=i;
		}
		for(int i=1;i<=m;i++){
			getchar();
			scanf("%c%d%d",&c,&a,&b);
            if(c=='A'){
				if(same(a,b)==0)
				    cout<<"In different gangs."<<endl;
				else if(same(a,b)==1)
				     cout<<"In the same gang."<<endl;
				else
				    cout<<"Not sure yet."<<endl;
			}
			else{
				merge(a,b+n);//标记为敌人 
				merge(a+n,b);//标记为敌人 
			}
		}	
	}
	return 0;
}



 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值