poj-3279 ——Fliptile(dfs 先枚举第一行)

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:

给一个N行M列的矩阵,值分别为0和1,每次你可以选择将一个变成相反状态,同时,它周围的四个数也会变为相反状态。 
问:最少翻转多少次,可以将所有值都变成0 
多个解,输出翻转次数最少的(若有次数相同解,输出字典序小的) 
若无解,输出”IMPOSSIBLE”

这里就是先   dfs  出第一行所有的可能 ,然后再  dfs  下边的所有 行, 当最后一行全为 0 时,就是一种满足条件的情况了


#include<iostream>
using namespace std;
int n,m;
int ans[20][20];
int f[20][20];
int mp[20][20];
int minn=999999;

bool check(){//检查最后一行是不是都为0 
	for(int i=1;i<=m;i++){
		int temp=mp[n][i]+f[n-1][i]+f[n][i+1]+f[n][i-1]+f[n][i];// 
		if(temp%2)
		    return false;
	}
	return true;
}

void dfs(int k,int num){//第k行
	if(num>minn)//剪枝 
	    return ;
	if(k>n){
		if(check()&& minn>num){
            for(int i=1;i<=n;i++){//只有保证  num 是又一个最小值时  才给ans 赋值 
            	for(int j=1;j<=m;j++){
            		ans[i][j]=f[i][j];
				}
			}
			minn=num;
		}
		return ;
	}
	int len=0;
	for(int i=1;i<=m;i++){
		int temp=mp[k-1][i]+f[k-1][i]+f[k-1][i+1]+f[k-1][i-1]+f[k-2][i];// 
		if(temp%2){//需要翻 
			f[k][i]=1;
			len++;
		}
		else
		    f[k][i]=0;
	}
	dfs(k+1,num+len);//下一列 
}

void firstdfs(int k,int num){//第k列
	if(k>m){
		dfs(2,num);
		return ;
	}
	f[1][k]=0;
	firstdfs(k+1,num);//第一行下一列   不翻 
	f[1][k]=1;
	firstdfs(k+1,num+1);//翻 
}

int main(){
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			cin>>mp[i][j];
		}
	}
	firstdfs(1,0);//处理第一行 
	if(minn==999999)
	    printf("IMPOSSIBLE\n");
	else{
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				printf("%d ",ans[i][j]);
			}
			printf("\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值