NJFU比赛部分题解

13 篇文章 0 订阅

先放上几题的不同解法。

B

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 28417 Accepted Submission(s): 12033

Problem Description
“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.

Can you find the special integer for Ignatius?

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output
For each test case, you have to output only one line which contains the special number you have found.

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output
3
5
1

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int a[1111111];
int main(){
    int n;
    while(cin>>n){
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        sort(a+1,a+1+n);//排序
        printf("%d\n",a[(n+1)/2]);
    }
    return 0;
} 

G

Uniform Generator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26820 Accepted Submission(s): 10629

Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%’ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

Sample Input
3 5
15 20
63923 99999

Sample Output
3 5 Good Choice

    15        20    Bad Choice

 63923     99999    Good Choice

简单说,

kseedmodMOD
要集齐 0 ~ MOD - 1。
若a,p互质,那么
ap1=1(modp)
,费马小定理。
每次加
ap2
个a,那么加的值模p余1。
即可凑满 0-MOD-1
事实上,只要算到 MOD-1 生成余就满了。

#include <cstdio>
using namespace std;
int gcd(int a,int b){return b?gcd(b,a%b):a;}
int main(){
    int a,b;
    while(~scanf("%d%d",&a,&b)){
        printf("%10d%10d",a,b);
        puts(gcd(a,b)-1?"    Bad Choice\n":"    Good Choice\n");
    }
    return 0;
}

C

找最长回文子串。
字符串长度最大到10W。
有个Manacher算法,直接贴链接了。
Manacher

#include <bits/stdc++.h>
using namespace std;

int N;
string s;

void solve() {
    string s1;
    s1.resize(2 * s.size() + 2);
    s1[0] = '$';
    s1[1] = '#';
    for (int i = 0; i < s.size(); ++i) {
        s1[(i + 1) << 1] = s[i];
        s1[((i + 1) << 1) + 1] = '#';
    }
    vector<int> p(s1.size(), 0);
    int res = 0;
    for (int id = 0, i = 1; i < s1.size(); ++i) {
        if (p[id] + id > i) p[i] = min(p[2 * id - i], p[id] + id - i);
        else p[i] = 1;
        while (s1[i + p[i]] == s1[i - p[i]]) ++p[i];
        if (i + p[i] > id + p[id]) id = i;
        res = max(res, p[i]);
    }
    cout << res - 1 << endl;
}

int main() {
    cin >> N;
    while (N--) {
        cin >> s;
        solve();
    }
    return 0;
}

D

说实话,这题不好写,贴上一分别人的代码。
hihoCoder 压缩字符串解题报告

#include<iostream>
#include<algorithm>
#include<string>
#include<limits.h>
#include<unordered_map>
using namespace std;

unordered_map<string, int> mem;
int divid(string str){
    if(str.size() < 4) return str.size();
    if(mem.count(str)) return mem[str];
    int len = str.size(), Min = INT_MAX;
    for(int i = 1, j; i <= len/2; i++){
        string tem = str.substr(0, i);
        for(j = 0; j <= len-i; j+= i)
            if(str.substr(j, i) != tem) break;
        if(j >= len)
            return to_string(len/i).size() + 2 + divid(tem);
        if(len == 4) return 4;
    }
    for(int i = 1; i < len; i++){
        string left = str.substr(0, i), right = str.substr(i); 
        int val1 = divid(str.substr(0, i)), val2 = divid(str.substr(i));
        if(left.size() > 3) mem[left] = val1;
        if(right.size() > 3) mem[right] = val2;
        Min = min(Min , val1+val2);
    }
    return Min;
}

int main(){
    string str;
    int T;
    cin >> T;
    while(T--){
        cin >> str;
        cout << divid(str) << endl;
    } 
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值