L2-006 树的遍历(25分) c++代码

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

 代码:

//#include<iostream>
//#include<cstring>
//#include<cmath>
//#include<algorithm>
//#include<ctype.h>
//#include<stdio.h>
//#include<map>
#include<bits/stdc++.h>
using namespace std;

int hou[35],zhong[35],l[1000000];

void ceng(int root,int start,int end,int index){
	if(start>end) return;
	int i=start;
	l[index]=hou[root];
	while(zhong[i]!=hou[root]) i++;
	ceng(root-(end-i)-1,start,i-1,2*index+1);//左子树(下一个根=原根-右子树的个数-1)
	ceng(root-1,i+1,end,2*index+2);//右子树 
}

int main(){
	int n;
	cin>>n;
	for(int i=0;i<n;i++) cin>>hou[i];
	for(int i=0;i<n;i++) cin>>zhong[i];
	fill(l,l+1000000,-1);
	ceng(n-1,0,n-1,0);
    int f=0;
	for(int i=0;;i++){
        if(f==n) break;
		if(l[i]!=-1){
			if(i==0) cout<<l[i];
			else cout<<" "<<l[i];
            f++;
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值