PTA L2-006树的遍历C++

L2-006 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

解题思路:

本题的解题思路主要运用树的创建和树的层次遍历。

#include<iostream>
using namespace std;
#include<queue>
typedef struct tree 
{
	int data;
	tree* lchild;
	tree* rchild;
}Tree,*BitTree;
queue<BitTree>q;
int result[30];
BitTree createTree(int*a,int*b,int ba, int bi,int mi,int ma)
{
	BitTree T;
	T = new tree();
		T->data = a[bi];
		int i;
		for (i = mi; i <= ma; i++)
			if (a[bi] == b[i])
				break;
		int lb = i - mi;
		int rb = ma - i;
		if (lb > 0)
		{
			T->lchild = createTree(a, b, ba, ba + lb - 1, mi, mi + lb - 1);
		}
		else
			T->lchild = NULL;
		if (rb == 0)
		{
			T->rchild = NULL;
		}
		else
		{
			T->rchild = createTree(a, b, ba + lb, ba + lb + rb - 1, mi + lb + 1, mi + lb + rb);
		}
	return T;
}
void levelTree(BitTree t)
{
	BitTree p;
	q.push(t);
	int i = 0;
	while(!q.empty())
	{
		p = q.front();
		if (p->lchild)
			q.push(p->lchild);
		if (p->rchild)
			q.push(p->rchild);
		result[i] = q.front()->data;
		q.pop();
		i++;
	}
}
int main()
{
	int n;
	int a[30],b[30];
	cin >> n;
	for (int i = 0; i < n; i++)
		cin >> a[i];
	for (int i = 0; i < n; i++)
		cin >> b[i];
	BitTree t=createTree(a,b,0,n-1,0,n-1);
	levelTree(t);
	for (int i = 0; i < n-1; i++)
		cout << result[i]<<" ";
	cout << result[n - 1];
	return 0;
}
  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
要重排链表,可以采取以下步骤: 1. 定义链表节点结构体,包含一个值和一个指向下一个节点的指针。 ```c struct ListNode { int val; struct ListNode *next; }; ``` 2. 创建一个辅助函数,用于翻转链表的后半部分。 ```c struct ListNode* reverseList(struct ListNode* head) { struct ListNode *prev = NULL; struct ListNode *curr = head; struct ListNode *next = NULL; while (curr != NULL) { next = curr->next; curr->next = prev; prev = curr; curr = next; } return prev; } ``` 3. 定义一个辅助函数,用于合并两个链表。 ```c void mergeLists(struct ListNode* l1, struct ListNode* l2) { struct ListNode *temp1; struct ListNode *temp2; while (l2 != NULL) { temp1 = l1->next; temp2 = l2->next; l1->next = l2; l2->next = temp1; l1 = temp1; l2 = temp2; } } ``` 4. 定义主函数,实现链表重排。 ```c void reorderList(struct ListNode* head) { if (head == NULL || head->next == NULL) { return; } // 找到链表中点 struct ListNode *slow = head; struct ListNode *fast = head; while (fast->next != NULL && fast->next->next != NULL) { slow = slow->next; fast = fast->next->next; } // 翻转链表的后半部分 struct ListNode *reversed = reverseList(slow->next); slow->next = NULL; // 合并前半部分和翻转后的后半部分 mergeLists(head, reversed); } ``` 这样,当你有一个链表头节点 `head` 后,你可以调用 `reorderList(head)` 函数来重排链表。请注意,在调用函数之前,请确保该链表的节点顺序是正确的。 希望这能帮到你!如果有任何问题,请随时提问。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值