Substring子序列

Description

Dr lee cuts a string S into N pieces,s[1],…,s[N].   

Now, Dr lee gives you these N sub-strings: s[1],…s[N]. There might be several possibilities that the string S could be. For example, if Dr. lee gives you three sub-strings {“a”,“ab”,”ac”}, the string S could be “aabac”,”aacab”,”abaac”,…   

Your task is to output the lexicographically smallest S. 

Input

        The first line of the input is a positive integer T. T is the number of the test cases followed.   

The first line of each test case is a positive integer N (1 <=N<= 8 ) which represents the number of sub-strings. After that, N lines followed. The i-th line is the i-th sub-string s[i]. Assume that the length of each sub-string is positive and less than 100. 

Output

The output of each test is the lexicographically smallest S. No redundant spaces are needed. 

Sample Input
 Copy sample input to clipboard
1
3
a
ab
ac

Sample Output
aabac

Problem Source: ZSUACM Team Member


我的解法:
#include <iostream>
#include <vector>
#include <string>
#include <algorithm>


using namespace std;


bool myComp(const string &s1,const string &s2)   //自定义比较方法
{
if((s1+s2<s2+s1))
return 1;
else
return 0;
    
}


int main()
{
int num;
string temp;
cin>>num;
for(int x=0;x<num;x++)                     //保存序列
{
int total;
cin>>total;
vector<string> s;
for(int y=0;y<total;y++)
{
cin>>temp;
s.push_back(temp);
}
sort(s.begin(),s.end(),myComp);    //排序
vector<string>::iterator it;
for(it=s.begin();it!=s.end();it++)    
{
cout<<*it;
}
cout<<endl;
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值