Factorial

Factorial
Time Limit: 1500MS Memory Limit: 65536K
Total Submissions: 12996 Accepted: 8078

Description

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically. 

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high even for a relatively small N. 

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function. 

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1 < N2, then Z(N1) <= Z(N2). It is because we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently. 

Input

There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output

For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input

6
3
60
100
1024
23456
8735373

Sample Output

0
14
24
253
5861
2183837

 

 

思路分析:

每次只计算最多含有5,5^2,5^3……的数字个数
每次含有5的[n/5]
........25.[n/25]

注意,当统计最多含有5^2的因子的时候,5的个数应该为[n/25]而不是[n/25]*2因为,在含有[n/5]的时候已经统计过一次了
所以,只需要把[n/5],[n/25]...加起来就可以了

例如1~100中
(1)含有5的:5,10,15....总计100/5=20个,每个之中含有1个5,总5因子数为20
(2)含有25的:25,50,75,100,总计100/25=4个,每个之中含有2个5,但是因为在(1)中含5的数字已经统计过一次因子,所以这里仍然记录因子个数1*5个
。。。。所以1~100中含有5的因子一共100/5+100/25=24个

1~N中的所有数字相乘,能拆分成的最简形式为素数的相乘(1忽略),其中2的个数多于5的个数(2的倍数多于5的倍数),所以,N!中,因子5有多少个,最后N!的末尾的0就有多少个。

 

 

代码:

#include<cstdio>

int prime[2000000];
__int64 fun(int n)
{
	long long cnt=5;
	long long sum=0;
	while(cnt<=n)
	{
		sum+=n/cnt;
		cnt*=5;
	}
	return sum;
}
int main()
{
	long long N;
	int T;
	while(scanf("%lld",&T)!=EOF)
	{
		while(T--)
		{
			scanf("%lld",&N);
			printf("%lld\n",fun(N));
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值