hdu 1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6064    Accepted Submission(s): 3854


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

Recommend
Eddy

解题思路:第一次完全靠自己写出来的搜索题,纪念一下,用的是BFS,用了模版类"优先队列",把每个搜索到的数据放入队列中,然后计数器的值增加一,把搜索过的值用vis数组进行标记,这样可以不改变mp数组的值,避免常见的错误发生。
还有当初wa的原因时像
@#..
#...
....
....
答案为1,而自己的答案却是0,希望对wa的同学有所帮助。

代码:
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
struct node
{
	int x,y;
	int num;
	friend bool operator < (node n1,node n2)
	{
		return n2.x<n1.x;
	}
};

int mp[25][25],n,m,si,sj,ans;
int dir[4][2]={1,0,-1,0,0,1,0,-1};
int vis[25][25];

int notinmap(int a,int b)
{
	if(a<0||a>=m||b<0||b>=n)
		return 1;
	if(mp[a][b]=='#')
		return 1;
	return 0;
}

void bfs()
{
	priority_queue<node>Q;
	while(!Q.empty()) Q.pop();
	
	memset(vis,0,sizeof(vis));
	node cur,next;
	cur.x=si;
	cur.y=sj;
	cur.num=0;
	Q.push(cur);
	while(!Q.empty())
	{
		cur=Q.top();
		Q.pop();
		for(int i=0;i<4;i++)
		{
			next.x=cur.x+dir[i][0];
			next.y=cur.y+dir[i][1];
			
			if(notinmap(next.x,next.y)) continue;
			if(vis[next.x][next.y]) continue;
			 
			Q.push(next);
			vis[next.x][next.y]=1;
			ans++;
		}	
	}
}

int main()
{
	char str[25];
	while(scanf("%d%d",&n,&m)&&(n+m))
	{
		getchar();
		ans=0,si=0,sj=0;
		for(int i=0;i<m;i++)
		{
			scanf("%s",str);
			for(int j=0;str[j];j++)
			{
				if(str[j]=='@')
				{
					si=i;
					sj=j;
				}
				mp[i][j]=str[j];
			}
		}
		//printf("%d %d\n",si,sj);
		bfs();
		if(ans==0)
			printf("%d\n",1);
		else
			printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值