Hard to Play

Time Limit: 2 Seconds Memory Limit: 65536 KB
MightyHorse is playing a music game called osu!.

After playing for several months, MightyHorse discovered the way of
calculating score in osu!:

  1. While playing osu!, player need to click some circles following the rhythm. Each time a player clicks, it will have three different
    points: 300, 100 and 50, deciding by how clicking timing fits the
    music.

  2. Calculating the score is quite simple. Each time player clicks and gets P points, the total score will add P, which should be calculated
    according to following formula:

P = Point * (Combo * 2 + 1) Here Point is the point the player gets
(300, 100 or 50) and Combo is the number of consecutive circles the
player gets points previously - That means if the player doesn’t miss
any circle and clicks the ith circle, Combo should be i - 1.

Recently MightyHorse meets a high-end osu! player. After watching his
replay, MightyHorse finds that the game is very hard to play. But he
is more interested in another problem: What’s the maximum and minimum
total score a player can get if he only knows the number of 300, 100
and 50 points the player gets in one play?

As the high-end player plays so well, we can assume that he won’t miss
any circle while playing osu!; Thus he can get at least 50 point for a
circle.

Input

There are multiple test cases.

The first line of input is an integer T (1 ≤ T ≤ 100), indicating the
number of test cases.

For each test case, there is only one line contains three integers: A
(0 ≤ A ≤ 500) - the number of 300 point he gets, B (0 ≤ B ≤ 500) - the
number of 100 point he gets and C (0 ≤ C ≤ 500) - the number of 50
point he gets.

Output

For each test case, output a line contains two integers, describing
the minimum and maximum total score the player can get.

Sample Input

1
Sample Output

2050 3950

注:是时候看看英语课本了

#include<stdio.h>
#include<string.h>
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        int x[1600],y[1600];
        for(int i=1 ; i<=a; i++)
            x[i]=300;
        for(int i=a+1; i<=a+b; i++)
            x[i]=100;
        for(int i=a+b+1; i<=a+b+c; i++)
            x[i]=50;
        int maxn=0,minn=0;
        for(int i=1; i<=a+b+c; i++)
        {
            maxn=maxn+(((i-1)*2+1))*x[i];
        }
        for(int i=1; i<=c; i++)
            y[i]=50;
        for(int i=c+1; i<=c+b; i++)
            y[i]=100;
        for(int i=c+b+1; i<=a+b+c; i++)
            y[i]=300;
        for(int i=1; i<=a+b+c; i++)
        {
            minn=minn+(((i-1)*2+1))*y[i];
        }
        printf("%d %d\n",maxn,minn);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值