ionic打包android报错处理use a compatible library with a minSdk of at most 16

报错提示:

Suggestion: use a compatible library with a minSdk of at most 16,
                or increase this project's minSdk version to at least 22,

               or use tools:overrideLibrary="org.apache.cordova" to force usage (may lead to runtime failures)-sqlcipher-3.5.9.aar

解决方案:

根据提示有三种解决方案

1.Suggestion: use a compatible library with a minSdk of at most 16:将三方库的minSdkVersion降低,这种方案一般是不可行,我们自己无法修改对方的SDK的minSdkVersion。

2.increase this project's minSdk version to at least 22:提高自己项目的minSdkVersion大于等于三方的即可,我这边是提示最新22版本

3.use tools:overrideLibrary="org.apache.cordova" to force usage (may lead to runtime failures)-sqlcipher-3.5.9.aar:

AndroidMainifest.xml中加入下面代码,如上图所示:

xmlns:tools="http://schemas.android.com/tools"
<uses-sdk tools:overrideLibrary="第三方库的包名"/>

注意:第三方库的报名根据你的报错提示添加,例如我的根据上面报错信息就是

<uses-sdk tools:overrideLibrary="org.apache.cordova" />

 

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页