HDOJ-1019(Java)

Q:

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input:

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output:

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input:

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output:

105
10296

Analysis:

纯属水题,复习下最基础的LCM和GCD。

Code:

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n=in.nextInt();
        while (n-->0) {
            long nums=in.nextLong();
            long []factors=new long[(int) nums];
            for(int i=0;i<nums;i++) {
                factors[i]=in.nextLong();
            }
            if(nums==1) {
                System.out.println(factors[0]);
            }else if (nums==2) {
                System.out.println((factors[1]*factors[0])/(GCD(factors[0], factors[1])));
            }else {
                long gcd=1;
                for(int i=0;i<nums;i++) {
                    gcd=LCM(gcd, factors[i]);
                }
                System.out.println(gcd);
            }
        }

    }
    /**
     * 最小公倍数
     * @param a
     * @param b
     * @return
     */
    public static long LCM(long a,long b) {
        return a*b/GCD(a, b);
    }

    /**
     * 最大公约数
     * @param a
     * @param b
     * @return
     */
    public static long GCD(long a,long b) {
        if(b==0) {
            return a;
        }else {
            return GCD(b,a%b);
        }
    }

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值