hdu 1019 Least Common Multiple

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 62729    Accepted Submission(s): 23974

 

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2

3 5 7 15

6 4 10296 936 1287 792 1

Sample Output

105 10296

Source

East Central North America 2003, Practice

Recommend

JGShining

#include <bits/stdc++.h>

using namespace std;

int gcd(int x, int y);
int main(){
    int n, m, x, y, a, b, l;
    cin >> n;
    while(n--){
        cin >> m;
        cin >> a;
        l = a; //当前的最小公倍数
        while(--m){
            cin >> a;
            l = l/gcd(l, a) * a; //这里如果先乘后除的话,可能会出现超出int限制的数。。这里就比较坑
        }
        cout << l << endl;
    }
    return 0;
}
int gcd(int x, int y){
    if(!y)   return x;
    else   return gcd(y, x%y);
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值