【HDU 2767】Proving Equivalences (Tarjan 缩点)

30 篇文章 0 订阅
13 篇文章 0 订阅

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5184 Accepted Submission(s): 1811
Problem Description
Consider the following exercise, found in a generic linear algebra textbook.
Let A be an n × n matrix. Prove that the following statements are equivalent:
1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.
The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.
Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!
I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:
* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
Output
Per testcase:
* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input
  
  
2 4 0 3 2 1 2 1 3
Sample Output
  
  
4 2
Source
Recommend
lcy | We have carefully selected several similar problems for you:27682766 2769 2773 2772

[题意][给定一个有向图和一些边,计算还需加入几条边使之成为一个强连通分量]

【题解】【Tarjan算法,缩点,多组数据,别忘清零。】
【几个特判:①没有给边的情况:直接输出n;②缩点后就剩一个点的情况:输出零】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[500010],nxt[500010],p[200010],tot;
int dft[200010],dis[200010],f[200010],cnt,root;
int in[200010],out[200010];
int n,m,N,d[200010],top;
bool vis[200010];

inline void add(int x,int y)
{
	tot++; a[tot]=y; nxt[tot]=p[x]; p[x]=tot;
}
inline void clear()
{
	memset(nxt,-1,sizeof(nxt)); memset(p,-1,sizeof(p));
	memset(dft,0,sizeof(dft));  memset(dis,0,sizeof(dis));
	memset(vis,0,sizeof(vis));	memset(d,0,sizeof(d));
	memset(out,0,sizeof(out));  memset(in,0,sizeof(in));
	memset(f,0,sizeof(f));
	tot=cnt=root=top=0;
}

void tarjan(int x)
{
	dft[x]=dis[x]=++cnt;
	d[++top]=x; vis[x]=1;
	int u=p[x];
	while(u>=0)
	 {
	 	if(!dft[a[u]])
	 	  tarjan(a[u]),dis[x]=min(dis[x],dis[a[u]]);
	 	 else 
	 	   if(vis[a[u]]) dis[x]=min(dis[x],dft[a[u]]);
	 	u=nxt[u];
	 }
	if(dis[x]==dft[x])
	 {
	 	root++;
	 	do{
	 		u=d[top--];
	 		vis[u]=0;
	 		f[u]=root;
	 	}while(u!=x);
	 }
	return;
}
inline void find()
{
	for(int i=1;i<=n;++i)
	 {
	 	int u=p[i];
	 	while(u>=0)
	 	 {
	 	 	if(f[a[u]]!=f[i])
	 	 	  out[f[i]]++,in[f[a[u]]]++;
	 	 	u=nxt[u];
	 	 }
	 }
	return;
}

int main()
{
	int i,j;
	scanf("%d",&N);
	for(i=1;i<=N;++i)
	 {
	    clear();
	 	scanf("%d%d",&n,&m);
	 	if(!m) {printf("%d\n",n); continue;}
	 	for(j=1;j<=m;++j)
	 	 {
	 	 	int x,y;
	 	 	scanf("%d%d",&x,&y);
	 	 	add(x,y);
	 	 }
	 	for(j=1;j<=n;++j)
	 	 if(!dft[j]) tarjan(j);
	 	if(root==1) {printf("0\n"); continue;}
		find(); 
		int inr=0,outr=0;
		for(j=1;j<=root;++j)
		 {
		 	if(!in[j]) inr++;
		 	if(!out[j]) outr++;
		 }
		printf("%d\n",max(inr,outr));
	 }
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值