【hdu 3336】Count the string(kmp)

27 篇文章 0 订阅
13 篇文章 0 订阅

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9230    Accepted Submission(s): 4292


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
  
  
1 4 abab
 

Sample Output
  
  
6
 

Author
foreverlin@HNU
 

Source
 

Recommend
lcy
 
【题解】【kmp】
【kmp的水题,只要将函数建出来,然后将以逐位为结尾的字符串在原串中出现的次数加起来即可,注意多组数据】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[200010];
int len,t,nxt[200010],ans;
inline void next()
{
    int i,j;
    nxt[0]=-1;
    for (i=0;i<len;++i)
      {
          j=nxt[i];
          while (j!=-1&&s[j]!=s[i]) j=nxt[j];
          nxt[i+1]=j+1;
      }
    return;
}
int main()
{
    int i,j;
    scanf("%d",&t);
    for (i=1;i<=t;++i)
     {
         int k;
        ans=0;
        scanf("%d",&len);
         scanf("%s",s);
         next();
         for (j=1;j<=len;++j)
           {
               k=nxt[j];
               while (k!=-1)
                {k=nxt[k]; ans=(ans+1)%10007;}
           }
        printf("%d\n",ans);
     }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值