【POJ 1201】Intervals(差分约束+SPFA)

43 篇文章 0 订阅
41 篇文章 0 订阅
Intervals
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25721 Accepted: 9843

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

【题解】【差分约束】
【约束条件为 a[y+1]-a[x]>=c[i],a[x+1]-a[x]<=1,a[x+1]-a[x]>=0,全部转化为>=,跑最长路即可】

#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[500010],next[500010],p[50010],val[500010],tot;
int dis[500010],minn=0x7fffffff,maxn,ans,n;
bool b[500010];

inline void add(int x,int y,int z)
{
	tot++; a[tot]=y; next[tot]=p[x]; p[x]=tot; val[tot]=z;
	return ;
}
inline int spfa(int s,int t)
{
	memset(dis,-1,sizeof(dis));
	memset(b,true,sizeof(b));
	queue<int>que;
	que.push(s); b[s]=false; dis[s]=0;
	while (!que.empty())
	 {
	  int u,v;
	  u=que.front(); que.pop();
	  v=p[u]; b[u]=true;
	  while (v!=0)
	   {
	   	if (dis[a[v]]<dis[u]+val[v])
	     {
	   	  dis[a[v]]=dis[u]+val[v];
	   	  if (b[a[v]])
	   	    {
	   	 	  b[a[v]]=false;
	   	 	  que.push(a[v]);
			}
		   }	
	    v=next[v];
	   }
	 }
	return dis[t];
}
int main()
{
	int i,j;
	scanf("%d",&n);
	for (i=1;i<=n;++i)
	 {
	 	int x,y,z;
	 	scanf("%d%d%d",&x,&y,&z);
	 	minn=min(x,minn); maxn=max(y+1,maxn);
	 	add(x,y+1,z);
	 }
	for (i=minn;i<maxn;++i)
	 {add(i+1,i,-1); add(i,i+1,0);}
	ans=spfa(minn,maxn);
	printf("%d",ans);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值