【bzoj 3048】[Usaco2013 Jan]Cow Lineup(单调队列)

3048: [Usaco2013 Jan]Cow Lineup

Time Limit: 2 Sec   Memory Limit: 128 MB
Submit: 160   Solved: 121
[ Submit][ Status][ Discuss]

Description

 Farmer John's N cows (1 <= N <= 100,000) are lined up in a row. Each cow is identified by an integer "breed ID" in the range 0...1,000,000,000; the breed ID of the ith cow in the lineup is B(i). Multiple cows can share the same breed ID. FJ thinks that his line of cows will look much more impressive if there is a large contiguous block of cows that all have the same breed ID. In order to create such a block, FJ chooses up to K breed IDs and removes from his lineup all the cows having those IDs. Please help FJ figure out the length of the largest consecutive block of cows with the same breed ID that he can create by doing this.

给你一个长度为n(1<=n<=100,000)的自然数数列,其中每一个数都小于等于10亿,现在给你一个k,表示你最多可以删去k类数。数列中相同的数字被称为一类数。设该数列中满足所有的数字相等的连续子序列被叫做完美序列,你的任务就是通过删数使得该数列中的最长完美序列尽量长。

Input

* Line 1: Two space-separated integers: N and K. 
* Lines 2..1+N: Line i+1 contains the breed ID B(i). 

Output


* Line 1: The largest size of a contiguous block of cows with identical breed IDs that FJ can create.

Sample Input

9 1
2
7
3
7
7
3
7
5
7

INPUT DETAILS: There are 9 cows in the lineup, with breed IDs 2, 7, 3, 7, 7, 3, 7, 5, 7. FJ would like to remove up to 1 breed ID from this lineup.

Sample Output

4

OUTPUT DETAILS: By removing all cows with breed ID 3, the lineup reduces to 2, 7, 7, 7, 7, 5, 7. In this new lineup, there is a contiguous block of 4 cows with the same breed ID (7).

HINT

样例解释:

  长度为9的数列,最多只能删去1类数。

  不删,最长完美序列长度为2.

  删去一类数3,序列变成2 7 7 7 7 5 7,最长完美序列长度为4.因此答案为4.

Source

[ Submit][ Status][ Discuss]

【题解】【单调队列】

维护一个含有k+1种元素的单调队列。首先在初始的时候,存每个元素的序号,然后将元素排序,便于记录有多少种不同的情况。在维护队列时,如果超过k+1种,就把前面的元素一一删,删至剩k+1种元素,每次向队列里加元素时都要比较当前的最优解和当前的元素出现次数的大小关系

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[100010],kind[100010],num[100010],d[100010],h,n,k;
int ans;
inline int tmp(int x,int y)
{
  return a[x]<a[y];
}
int main()
{
    int i,j;
    scanf("%d%d",&n,&k);
    for(i=1;i<=n;++i) scanf("%d",&a[i]),num[i]=i;
    sort(num+1,num+n+1,tmp);
    a[0]=-1; int tot=0;
    for(i=1;i<=n;++i)
     {
        if(a[num[i-1]]!=a[num[i]]) tot++;
        kind[num[i]]=tot;
    }
    tot=0;
    for(i=1;i<=n;++i)
     {
        ++d[kind[i]];
        if(d[kind[i]]==1)
         {
            tot++;
            while (tot>k+1)
             {
                d[kind[h]]--;
                if (!d[kind[h]]) tot--;
                h++; 
            } 
        }
        ans=max(ans,d[kind[i]]);
    }
    printf("%d\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值