【hdu 1695】GCD(莫比乌斯反演)

30 篇文章 0 订阅
5 篇文章 0 订阅

GCD

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10201 Accepted Submission(s): 3849

Problem Description

Given 5 integers: a, b, c, d, k, you’re to find x in a…b, y in c…d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you’re only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.
Yoiu can assume that a = c = 1 in all test cases.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

Output

For each test case, print the number of choices. Use the format in the example.

Sample Input

2
1 3 1 5 1
1 11014 1 14409 9

Sample Output

Case 1: 9
Case 2: 736427

HintFor the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

Source

2008 “Sunline Cup” National Invitational Contest

Recommend
wangye | We have carefully selected several similar problems for you: 1689 1690 1693 1691 1698

[题意][求 x[a,b]y[c,d]gcd(xy)=k xy 的个数, gcd(xy)gcd(yx) 算一种.在本题中,a和c恒为1]
【题解】

x=1by=1dgcd(x,y)=k

=x=1by=1d[k|i][d|j][(ik,jk)=1]

x=kxy=ky
=x=1bky=1dk[(xy)=1]

[n=1]=d|nμ(d)

bk=ndk=mx=x,y=yN=min(n,m)

=d=1Nx=1ny=1m[d|x][d|y]μ(d)

=d=1Nx=1n[d|x]y=1m[d|y]μ(d)

=d=1Nxdydμ(d)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int prime[100010],miu[100010];
int a,b,c,d,k,t;
bool p[100010];
inline void shai(int n)
{
    int i,j;
    miu[1]=1;
    for (i=2;i<=n;++i)
     {
         if(!p[i]) prime[++prime[0]]=i,miu[i]=-1;
         for (j=1;j<=prime[0];++j)
          {
              if (i*prime[j]>n) break;
              p[i*prime[j]]=1;
              if (!(i%prime[j])) {miu[i*prime[j]]=0;break;}
               else miu[i*prime[j]]=-miu[i];
          }
     }
}
int main()
{
    int i,j;
    scanf("%d",&t);
    shai(100000);
    for (i=1;i<=t;++i)
     {
         scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
         if (!k) {printf("Case %d: 0\n",i); continue;}
         long long ans1=0,ans2=0;
         b/=k; d/=k;
         if (b>d) swap(b,d);
         for (j=1;j<=b;++j) ans1+=(long long)(b/j)*(d/j)*miu[j];
         for (j=1;j<=b;++j) ans2+=(long long)(b/j)*(b/j)*miu[j];
         ans1-=ans2/2;
         printf("Case %d: %I64d\n",i,ans1);
     }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值