Cash Machine

Cash Machine (背包)

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

翻译

一家银行计划安装一台取款机。该机器能够为要求的现金金额提供适当的@账单。机器使用N种不同的票据面值,例如dk,k=1,n,并且对于每个面值dk,机器都有一个NK票据供应。例如,

n=3,n1=10,d1=100,n2=4,d2=50,n3=5,d3=10

意味着机器每台有10张@100的账单,每台有4张@50的账单,每台有5张@10的账单。

调用现金机器应交付的所需现金量,并编写一个程序,计算根据机器的可用票据供应量可有效交付的最大现金量小于或等于现金。

笔记:
@是机器交付货币的符号。例如,@可以代表美元、欧元、英镑等。
输入
程序输入来自标准输入。输入中的每个数据集代表一个特定事务,其格式如下:

现金n n1 d1 n2 d2…神经网络DN

其中0<=cash<=100000是所需现金金额,0<=n<=10是票据面额的数量,0<=n k<=1000是丹麦面额的可用票据数量,1<=dk<=1000,k=1,n。输入中的数字之间可以自由出现空白。输入数据正确。
输出
对于每一组数据,程序将结果打印到单独一行上的标准输出,如下面的示例所示。
样本输入
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0个
0 3 10 100 10 50 10 10 10 10
样品输出
735个
630个
0
0
提示
第一个数据集指定请求的现金金额为@735的交易。机器包含3个钞票面值:4张@125,6张@5,3张@350。这台机器可以交付所要求的确切金额的现金。

在第二种情况下,机器的帐单供应不符合要求的确切现金金额。可交付的最大现金为@630。请注意,有几种方法可以将票据组合到机器中,以匹配已交付的现金。

在第三种情况下,机器是空的,没有现金交付。在第四种情况下,请求的现金金额为@0,因此,机器不提供现金。

思路

由题意可知,给你一个总钱数,然后给你n种兑换方式。每种兑换方式给出 x个bills可以兑换y个@。最后让你求可用y的最大值。

是一个多重背包问题,用模板,但是其中cost和wei是一个变量。(可以用二进制转化为01背包)

代码

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 100005
using namespace std;
int dp[N],t;
void dfs(int p)
{
    for(int v=t;v>=p;v--)
    {
        if(dp[v]<dp[v-p]+p)
            dp[v]=dp[v-p]+p;
    }
}
void bfs(int p)
{
    for(int v=p;v<=t;v++)
    {
        if(dp[v]<dp[v-p]+p)
            dp[v]=dp[v-p]+p;
    }
}
void mu(int p,int n)
{
    if(p>t)
        return;
    if(p+n==t)
        bfs(p);
    else
    {
        int k=1;
        while(k<n)
        {
            dfs(k*p);
            n=n-k;
            k=k*2;
        }
        dfs(n*p);
    }
}
int main()
{
    int m,i,n[15],d[15];
    while(scanf("%d",&t)>0)
    {
        scanf("%d",&m);
        for(i=1;i<=m;i++)
            scanf("%d%d",&n[i],&d[i]);
        for(i=0;i<=t;i++)
            dp[i]=0;
        for(i=1;i<=m;i++)
            mu(d[i],n[i]);
        printf("%d\n",dp[t]);
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值