Quadtrees(四叉树)
A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree
is that any image can be split into four quadrants. Each quadrant may again be split in four sub
quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants
are represented by four child nodes, in a predetermined order.
Of course, if the whole image is a single color, it can be represented by a quadtree consisting of
a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different
colors. As a result, the quadtree need not be of uniform depth.
A modern computer artist works with black-and-white images of 32 × 32 units, for a total of 1024
pixels per image. One of the operations he performs is adding two images together, to form a new
image. In the resulting image a pixel is black if it was black in at least one of the component images,
otherwise it is white.
This particular artist believes in what he calls the preferred fullness: for an image to be interesting
(i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the
image. So, before adding two images together, he would like to know how many pixels will be black
in the resulting image. Your job is to write a program that, given the quadtree representation of two
images, calculates the number of pixels that are black in the image, which is the result of adding the
two images together.
In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string
(defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.
Input
The first line of input specifies the number of test cases (N) your program has to process.
The input for each test case is two strings, each string on its own line. The string is the pre-order
representation of a quadtree, in which the letter ‘p’ indicates a parent node, the letter ‘f’ (full) a black
quadrant and the letter ‘e’ (empty) a white quadrant. It is guaranteed that each string represents a
valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).
Output
For each test case, print on one line the text ‘There are X black pixels.’, where X is the number
of black pixels in the resulting image.
Sample Input
3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe
Sample Output
There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.
大意
有一个1024个像素的格子,按照从左到右从上到下2,1,3,4这样建树,p表示这个节点的子节点有黑有白,f(full)表示充满了黑色(子节点全为黑,不许表示子节点了),e(empty)表示其中全为白,合并两颗二叉树,为黑色像素到底有多少(奇妙的是四叉树只需要先序遍历就可以得到整棵树的建树)
思路
由于给的是四分图的先序遍历,那么这个图也就可以画出来了,于是可以边建图,边画图,如果遇到黑色像素f就画图,如果遇到p就递归建图;
其中x,y表示坐上点的位置,len代表当前图的面积;
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<math.h>
#include<algorithm>
using namespace std;
const int len=32;
const int maxn=32*32+10;
char s[maxn];
int ans,a[len][len];
void draw(char s[],int &p,int r,int c,int w)
{
char ch=s[p++];
if(ch=='p')
{
draw(s,p,r,c+w/2,w/2);
draw(s,p,r,c,w/2);
draw(s,p,r+w/2,c,w/2);
draw(s,p,r+w/2,c+w/2,w/2);
}
else if(ch=='f')
{
for(int i=r; i<r+w; i++)
{
for(int j=c; j<c+w; j++)
{
if(!a[i][j])
{
a[i][j]=1;
ans++;
}
}
}
}
}
int main()
{
int y;
scanf("%d",&y);
while(y--)
{
memset(a,0,sizeof(a));
ans=0;
for(int i=0; i<2; i++)
{
scanf("%s",s);
int p=0;
draw(s,p,0,0,len);
}
printf("There are %d black pixels.\n",ans);
}
return 0;
}