HDU1069 Monkey and Banana(动态规划,单调最长递减子序列)

题目:

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13354    Accepted Submission(s): 7041


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
 

Recommend
JGShining
 

Statistic |  Submit |  Discuss |  Note
思路:

题目的意思是有很多砖块,长宽高为x,y,z,一共有六种情况,每种规格的砖有无限件可用,但是要求底下的砖的长宽高一定要大于上面的砖的长宽高,求最后砖块能落成的最高高度,先把六种不同的情况都列出来放进结构体里,然后从小到大排序,然后把每一个与比他多的其他的比较找出最大值。

代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
struct node
{
    int x,y,z;
    int dp;
};
node a[500];
bool cmp(node a,node b)
{
    if(a.x!=b.x)
        return a.x>b.x;//按照长从大到小排列
    else
        return a.y>b.y;
}
int main()
{
    int n;
    int s=1;
    while(scanf("%d",&n)&&n)
    {
        int i;
        int k=0;
        memset(a,0,sizeof(a));
        for(i=0; i<n; i++)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);//列出所有的情况,一共六种,拆开
            a[k].x=x,a[k].y=y,a[k].z=a[k].dp=z,k++;
            a[k].x=x,a[k].y=z,a[k].z=a[k].dp=y,k++;
            a[k].x=y,a[k].y=x,a[k].z=a[k].dp=z,k++;
            a[k].x=z,a[k].y=x,a[k].z=a[k].dp=y,k++;
            a[k].x=z,a[k].y=y,a[k].z=a[k].dp=x,k++;
            a[k].x=y,a[k].y=z,a[k].z=a[k].dp=x,k++;
        }
        sort(a,a+k,cmp);
        int maxx=a[0].dp;
        int j;
        for(i=1; i<k; i++)
        {
            for(j=i-1; j>=0; j--)
            {
                if(a[j].x>a[i].x&&a[j].y>a[i].y&&(a[i].dp<a[j].dp+a[i].z))//需要满足题意,当且仅当下面的长和宽都大于上面的时候,且高度要大
                {
                    a[i].dp=a[j].dp+a[i].z;//更新高度
                }
                if(a[i].dp>maxx)
                    maxx=a[i].dp;//更新最大值
            }
        }
        printf("Case %d: maximum height = %d\n",s++,maxx);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值