POJ3450 Corporate Identity(kmp,最长公共子串)

Description

Beside other services, ACM helps companies to clearly state their
“corporate identity”, which includes company logo but also other
signs, like trademarks. One of such companies is Internet Building
Masters (IBM), which has recently asked ACM for a help with their new
identity. IBM do not want to change their existing logos and
trademarks completely, because their customers are used to the old
ones. Therefore, ACM will only change existing trademarks instead of
creating new ones.

After several other proposals, it was decided to take all existing
trademarks and find the longest common sequence of letters that is
contained in all of them. This sequence will be graphically emphasized
to form a new logo. Then, the old trademarks may still be used while
showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line
containing a positive integer N, the number of trademarks (2 ≤ N ≤
4000). The number is followed by N lines, each containing one
trademark. Trademarks will be composed only from lowercase letters,
the length of each trademark will be at least 1 and at most 200
characters.

After the last trademark, the next task begins. The last task is
followed by a line containing zero.

Output

For each task, output a single line containing the longest string
contained as a substring in all trademarks. If there are several
strings of the same length, print the one that is lexicographically
smallest. If there is no such non-empty string, output the words
“IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST

思路

还是求最长公共子串,和POJ3080一样

代码

#include<cstdio>
#include<cstring>
#include<string>
#include<set>
#include<iostream>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define mod 10000007
#define debug() puts("what the fuck!!!")
#define N 200+20
#define ll longlong
using namespace std;
int nxt[N];
string str[4500];
void get_next(string s)
{
    int len=s.length();
    int j=0,k=-1;
    nxt[0]=-1;
    while(j<len)
        if(k==-1||s[j]==s[k])
            nxt[++j]=++k;
        else
            k=nxt[k];
}
bool kmp(string p,string s)//判断s是不是p的子串
{
    int plen=p.length();
    int slen=s.length();
    int i=0,j=0;
    while(i<plen&&j<slen)
    {
        if(j==-1||p[i]==s[j])
        {
            i++;
            j++;
        }
        else
            j=nxt[j];
    }
    if(j==slen)
        return true;
    return false;
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    while(cin>>n&&n)
    {
        for(int i=0; i<n; i++)
            cin>>str[i];
        string ans="";
        for(int i=1; i<=str[0].size(); i++)
        {
            for(int j=0; j<=str[0].size()-i; j++)
            {
                string op=str[0].substr(j,i);
                get_next(op);
                int flag=0;
                for(int k=1; k<n; k++)
                    if(!kmp(str[k],op))
                    {
                        flag=1;
                        break;
                    }
                if(!flag)
                {
                    if(ans.size()<op.size())
                        ans=op;
                    else if(ans.size()==op.size())
                        ans=min(ans,op);
                }
            }
        }
        if(ans.size()==0)
            cout<<"IDENTITY LOST"<<endl;
        else
            cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值