HDU6197 array array array(LIS)

Problem Description

One day, Kaitou Kiddo had stolen a priceless diamond ring. But
detective Conan blocked Kiddo’s path to escape from the museum. But
Kiddo didn’t want to give it back. So, Kiddo asked Conan a question.
If Conan could give a right answer, Kiddo would return the ring to the
museum. Kiddo: “I have an array A and a number k, if you can choose
exactly k elements from A and erase them, then the remaining array is
in non-increasing order or non-decreasing order, we say A is a magic
array. Now I want you to tell me whether A is a magic array. ” Conan:
“emmmmm…” Now, Conan seems to be in trouble, can you help him?

Input

The first line contains an integer T indicating the total number of
test cases. Each test case starts with two integers n and k in one
line, then one line with n integers: A1,A2…An. 1≤T≤20 1≤n≤105 0≤k≤n
1≤Ai≤105

Output

For each test case, please output “A is a magic array.” if it is a
magic array. Otherwise, output “A is not a magic array.” (without
quotes).

Sample Input

3
4 1
1 4 3 7
5 2
4 1 3 1 2
6 1
1 4 3 5 4 6

Sample Output

A is a magic array.
A is a magic array.
A is not a magic array.

思路

给了一个序列,长度为n,问是否可以删去k个字符,使之成为非递增或者非递减子序列,我们求非递减的时候用upper_bound,再求非递增的时候只需要倒过来求非递减就行了,最后判断这个字符串删去后的长度如果小于等于非递增或非递减长度就可以了

代码

#include <cstdio>
#include <cstring>
#include <cctype>
#include <stdlib.h>
#include <string>
#include <map>
#include <iostream>
#include <set>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long ll;
const int N=1e5+20;
int a[N],b[N],c[N];
int main()
{
    int t,n,k;
    scanf("%d",&t);
    while(t--)
    {
        int len1=0,len2=0;
        scanf("%d%d",&n,&k);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0; i<n; i++)
        {
            int p=upper_bound(b,b+len1,a[i])-b;
            b[p]=a[i];
            if(p==len1)
                len1++;
        }
        for(int i=n-1; i>=0; i--)
        {
            int p=upper_bound(c,c+len2,a[i])-c;
            c[p]=a[i];
            if(p==len2)
                len2++;
        }
        if(n-k<=len1||n-k<=len2)
            puts("A is a magic array.");
        else
            puts("A is not a magic array.");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值