HDU 6197array array array(简单dp)

array array array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 341    Accepted Submission(s): 214


Problem Description
One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum. 
Kiddo: "I have an array  A  and a number  k , if you can choose exactly  k  elements from  A  and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say  A  is a magic array. Now I want you to tell me whether  A  is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him?
 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers  n  and  k  in one line, then one line with  n  integers:  A1,A2An .
1T20
1n105
0kn
1Ai105
 

Output
For each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes).
 

Sample Input
  
  
3 4 1 1 4 3 7 5 2 4 1 3 1 2 6 1 1 4 3 5 4 6
 

Sample Output
  
  
A is a magic array. A is a magic array. A is not a magic array.
 

Source
想法:递增递减子序列
代码:
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int a[100005],dp[100005],n;
int bin(int size,int k)
{
    int l = 1,r = size;
    while(l<=r)
    {
        int mid = (l+r)/2;
        if(k>dp[mid])
            l = mid+1;
        else
            r = mid-1;
    }
    return l;
}
int LIS()
{
    memset(dp,0,sizeof(dp));
    int i,j,ans=1;
    dp[1] = a[1];
    for(i = 2; i<=n; i++)
    {
        if(a[i]<=dp[1])
            j = 1;
        else if(a[i]>dp[ans])
            j = ++ans;
        else
            j = bin(ans,a[i]);
        dp[j] = a[i];
    }
    return ans;
}
int LIS1()
{
    memset(dp,0,sizeof(dp));
    int i,j,ans=1;
    dp[1] = a[1];
    for(i = 2; i<=n; i++)
    {
        if(a[i]>dp[1])
            j = 1;
        else if(a[i]<=dp[ans])
            j = ++ans;
        else
            j = bin(ans,a[i]);
        dp[j] = a[i];
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
      int k;
      scanf("%d %d",&n,&k);
      for(int i=1;i<=n;i++)
      {
          scanf("%d",&a[i]);
      }
     int ans1=n-LIS();
     int ans2=n-LIS1();
     //printf("%d %d\n",n-ans1,n-ans2);
     if(k>=ans1||k>=ans2)
        printf("A is a magic array.\n");
     else
        printf("A is not a magic array.\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值