IPv4向IPv6的过渡不是一次性的,而是逐步地分层次地。在过渡时期,为了保证IPv4和IPv6能够共存、互通,人们发明了一些IPv4/IPv6的互通技术。
本实验以6to4技术为例,阐述如何配置IPv6过渡技术。
配置参考
R1
#
sysname R1
#
ipv6
#
interface GigabitEthernet0/0/1
ip address 200.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/2
ipv6 enable
ipv6 address 2002:C801:101::FFFF/64
#
interface Tunnel0/0/0
ipv6 enable
ipv6 address auto link-local
tunnel-protocol ipv6-ipv4 6to4
source 200.1.1.1
#
ip route-static 0.0.0.0 0.0.0.0 200.1.1.2
#
ipv6 route-static 2002:C802:202:: 64 Tunnel0/0/0
R2
#
sysname R2
#
ipv6
#
interface GigabitEthernet0/0/1
ipv6 enable
ipv6 address 2002:C802:202::FFFF/64
#
interface GigabitEthernet0/0/2
ip address 200.2.2.2 255.255.255.0
#
interface Tunnel0/0/0
ipv6 enable
ipv6 address auto link-local
tunnel-protocol ipv6-ipv4 6to4
source 200.2.2.2
#
ip route-static 0.0.0.0 0.0.0.0 200.2.2.1
#
ipv6 route-static 2002:C801:101:: 64 Tunnel0/0/0
Internet
#
sysname internet
#
ipv6
#
interface GigabitEthernet0/0/1
ipv6 enable
ip address 200.1.1.2 255.255.255.0
ipv6 address 2002:C801:202::FFFF/64
#
interface GigabitEthernet0/0/2
ip address 200.2.2.1 255.255.255.0
PC
PC1>ipconfig
Link local IPv6 address...........: fe80::5689:98ff:fe7d:4b9f
IPv6 address......................: 2002:c801:101::1 / 64
IPv6 gateway......................: 2002:c801:101::ffff
PC2>ipconfig
Link local IPv6 address...........: fe80::5689:98ff:fe8e:67e1
IPv6 address......................: 2002:c802:202::1 / 64
IPv6 gateway......................: 2002:c802:202::ffff