sicily题目之2001 2005

2001. Scavenger Hunt
 
 
Total: 1099Accepted:500Rating:
1.0/5.0(2 votes)
 

   
 
Time Limit: 1s Memory Limit: 64MB
Description

Farmer John has scattered treats for Bessie at special places in the pasture. Since everyone knows that smart cows make tasty milk, FJ has placed the treats at locations that require Bessie to think. He has given her two numbers, P and Q (1 <= P <= 6,000; 1 <= Q <= 6,000), and she has to check every point in the pasture whose x-coordinate is a factor of P and whose y-coordinate is a factor of Q to find her treat.
Suppose FJ gives Bessie P = 24 and Q = 2. Here are all of their respective factors:
P = 24 => 1, 2, 3, 4, 6, 8, 12, 24
Q = 2 => 1, 2
Bessie would thus check grid locations: (1, 1), (1, 2), (2, 1), (2, 2), (3, 1)...
Help Bessie by printing all of the points she ought to check.

Input

* Line 1: Two space separated integers: P and Q

Output

* Lines 1..?: A complete list of unique pairs of space-separated integers sorted by the first number and, if tied, the second number: a factor of P followed by a factor of Q

Sample Input
Copy sample input to clipboard
24 2
Sample Output
1 1
1 2
2 1
2 2
3 1
3 2
4 1
4 2
6 1
6 2
8 1
8 2
12 1
12 2
24 1
24 2

#include<stdio.h>
int main()
{
int P,Q,p[100],q[100],i,j,k,l;
scanf("%d %d",&P,&Q);

for(i=1,j=0;i<=P;i++)
if(P%i==0)
{
p[j]=i;
j++;
}
for(i=1,k=0;i<=Q;i++)
if(Q%i==0)
{
q[k]=i;
k++;
}
for(i=0;i<j;i++)
for(l=0;l<k;l++)
printf("%d %d/n",p[i],q[l]);
}

 

2005. Lovely Number
 
 
Total: 1447Accepted:352Rating:
3.0/5.0(2 votes)
 

   
 
Time Limit: 1s Memory Limit: 64MB
Description

 

Every time after got a solution from kevin, ivan repeats again and again,"Are there any better ones?". It seems more worse this time. Given a sequence of numbers, which ivan is sure that all of them appear even times except only one "lovely number" appears odd times, kevin must find out the lovely number as soon as possible. So, let's rock!

Input

 

There are multiple test cases.

Each test case contains two lines. The first line is an integer N, 1 <= N <= 10001, and N % 2 = 1. The second line contains N integers, separated by spaces.

Input is terminated by EOF.

Output

 

For each test case, output a line of an integer, which should be the lovely number.

Sample Input
Copy sample input to clipboard
3
1 2 1
5
7 7 7 7 3
7
2 2 4 4 4 2 2

Sample Output
2
3
4
 
 

#include<stdio.h>
int main()
{
int temp=0,j,k,n,a[10002]={0};
while(1)
{
if(scanf("%d",&n)!=EOF)
{
for(j=0;j<n;j++)
{scanf("%d",&a[j]);}
for(k=0;k<n-1;k++)
for(j=k;j<n-1;j++)
if(a[k]==a[j+1])
{a[k]=0;a[j+1]=0;}
for(k=0;k<n;k++)
temp=temp+a[k];
printf("%d/n",temp);
temp=0;

}

else
break;
}


return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值