A hard puzzle(1097)

A hard puzzle

TimeLimit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K(Java/Others)
Total Submission(s): 14539 Accepted Submission(s):5135


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining andIgnatius: gave a and b,how to know the a^b.everybody objects tothis BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's thelast digit number.But everybody is too lazy to slove thisproblem,so they remit to you who is wise.

Input
There are mutiple test cases. Each test cases consists of twonumbers a andb(0<a,b<=2^30)

Output
For each test case, you should output the a^b's last digitnumber.

Sample Input
7 66 8800

Sample Output
9
6
AC代码
 
  
  • #include<iostream>
  • #include<cstdio>
  • using namespacestd;
  • intmain()
  • {
  • long long a,b;
  • intans[5];
  • while(cin>> a >>b)
  • {
  •  
  • ans[1] = a % 10;
  • ans[2] = (ans[1] * a ) % 10;
  • ans[3] = (ans[2] * a ) % 10;
  • ans[4] = (ans[3] * a ) % 10;
  • int tmp = b %4;
  • if( tmp == 0 ) tmp =4;
  • cout << ans[tmp]<< endl;
  • }
  • return 0;
  • }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值