1002 hdu (高精度)

A + B Problem II

TimeLimit: 2000/1000 MS(Java/Others)    MemoryLimit: 65536/32768 K (Java/Others)
Total Submission(s):108726    AcceptedSubmission(s): 20548


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integerT(1<=T<=20) which means the number oftest cases. Then T lines follow, each line consists of two positiveintegers, A and B. Notice that the integers are very large, thatmeans you should not process them by using 32-bit integer. You mayassume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is"Case #:", # means the number of the test case. The second line isthe an equation "A + B = Sum", Sum means the result of A + B. Notethere are some spaces int the equation. Output a blank line betweentwo test cases.
 

Sample Input
 
   
2 1 2112233445566778899 998877665544332211
 

Sample Output
 
   
Case1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 =1111111111111111110
 

Author
Ignatius.L
#include <stdio.h>
#include<string.h> 
int sum[1000];
void add (char a[] ,char b[])
{
     int i= strlen(a) - 1 ,j = strlen (b) - 1;
     int x= 0 ,s ,k = 0;
     while(i >= 0 && j>= 0)
    {
          s = a[i--]+ b[j--] - 96 + x ;
          sum[k++] =s % 10 ; 
          x = s / 10;
    }
     if (j== -1)
     while(i >= 0)
    {
         s = a[i--] - 48 + x ;
         sum[k++] = s % 10 ;
         x = s / 10 ;
    }
     if (i== -1)
     while(j >= 0)
    {
         s = b[j--] - 48 + x ;
         sum[k++] = s % 10 ;
         x = s / 10 ;
    }
     if(x)
     sum[k]= x ;
    else 
     k = k- 1 ;     
     for (i= k ;i >= 0 ;i--)
     printf("%d",sum[i]);
}
int main ()
{
     int t,i;
     chara[1000] ,b[1000];
     scanf("%d",&t);
     for (i= 1 ;i <= t ;i++)
    {
         memset(a , '0' ,sizeof(a));
         memset(b , '0' ,sizeof(b));
         scanf ("%s%s",a ,b);
         printf ("Case %d:\n%s + %s =",i ,a ,b);
         add (a ,b);
         printf ("\n");
         if(i != t)printf("\n");
    }
     return0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值