POJ 2503 Babelfish

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops


分析:字符串哈希。用map也可水过。

Code1(hash):

#include <algorithm>
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>
#include <map>
#include <set>
#define eps 1e-7
#define LL long long
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define Max(a,b) ((a)>(b)?(a):(b))
#define Min(a,b) ((a)<(b)?(a):(b))
using namespace std;

const int MOD=100007;
struct node{
    char s1[15],s2[15];
    int next;
}pos[MOD];
int head[MOD];
char str1[15],str2[15];

int GetKey(int len){
    int ans=0;
    for(int i=0;i<len;i++){
        ans=(ans*26+(str2[i]-'a'))%MOD;
    }
    return ans;
}

int main()
{
    int cnt=0;
    memset(head,-1,sizeof(head));
    while(str1[0]=getchar()){
        if(str1[0]=='\n') break;
        scanf("%s %s",&str1[1],str2);
        int tmp=GetKey(strlen(str2));
        strcpy(pos[cnt].s1,str1);
        strcpy(pos[cnt].s2,str2);
        pos[cnt].next=head[tmp];
        head[tmp]=cnt++;
        getchar();
    }
    while(scanf("%s",str2)!=EOF){
        int tmp=GetKey(strlen(str2));
        bool flag=false;
        for(int i=head[tmp];i!=-1;i=pos[i].next){
            if(strcmp(str2,pos[i].s2)==0){
                flag=true;
                printf("%s\n",pos[i].s1);
                break;
            }
        }
        if(!flag) printf("eh\n");
    }
    return 0;
}


Code2(map):

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<map>
using namespace std;
char s1[15],s2[15];
int main()
{
    map<string,string>data;
    map<string,bool>mark;
    while(1){
		s1[0]=getchar();
        if(s1[0]=='\n')break;
        scanf("%s",s1+1);
	    scanf("%s",s2);
        mark[s2]=true;
        data[s2]=s1;
	    getchar();
	}
	while(cin>>s1){
		if(mark[s1])printf("%s\n",data[s1].c_str());
		else        printf("eh\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值