[bzoj4396][Usaco2015 dec][并查集]High Card Wins

18 篇文章 0 订阅

Description

Bessie the cow is a huge fan of card games, which is quite surprising,
given her lack of opposable thumbs. Unfortunately, none of the other
cows in the herd are good opponents. They are so bad, in fact, that
they always play in a completely predictable fashion! Nonetheless, it
can still be a challenge for Bessie to figure out how to win. Bessie
and her friend Elsie are currently playing a simple card game where
they take a deck of 2N cards, conveniently numbered 1…2N, and divide
them into N cards for Bessie and N cards for Elsie. The two then play
N rounds, where in each round Bessie and Elsie both play a single
card, and the player with the highest card earns a point. Given that
Bessie can predict the order in which Elsie will play her cards,
please determine the maximum number of points Bessie can win.

奶牛Bessie和Elsie在玩一种卡牌游戏。一共有2N张卡牌,点数分别为1到2N,每头牛都会分到N张卡牌。

游戏一共分为N轮,因为Bessie太聪明了,她甚至可以预测出每回合Elsie会出什么牌。

每轮游戏里,两头牛分别出一张牌,点数大者获胜。

Bessie现在想知道,自己最多能获胜多少轮?

Input

The first line of input contains the value of N (1≤N≤50,000). The next
N lines contain the cards that Elsie will play in each of the
successive rounds of the game. Note that it is easy to determine
Bessie’s cards from this information.

Output

Output a single line giving the maximum number of points Bessie can
score.

Sample Input

3

1

6

4

Sample Output

2

HINT

Here, Bessie must have cards 2, 3, and 5 in her hand, and she can use
these to win at most 2 points by saving the 5 until the end to beat
Elsie’s 4.

Problem credits: Austin Bannister and Brian Dean

题解

排排序
并查集乱水。。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace std;
int a[110000],n;
bool v[110000];
int fa[110000];
int findfa(int x){return fa[x]!=x?fa[x]=findfa(fa[x]):fa[x];}
int main()
{
    memset(v,false,sizeof(v));
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d",&a[i]),v[a[i]]=true;
    sort(a+1,a+1+n);
    for(int i=1;i<=2*n;i++)fa[i]=i;
    fa[2*n+1]=2*n+1;
    for(int i=1;i<=n;i++)fa[a[i]]=findfa(fa[a[i]+1]);
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        int tmp=findfa(fa[a[i]+1]);
        if(tmp==2*n+1)break;
        ans++;fa[tmp]=findfa(fa[tmp]+1);
    }
    printf("%d\n",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值