1001. A+B Format (20)

今天开始刷PAT了,报了18号考试,剩下这几天一点信心都没有,甲级题库有139题,想把甲级题库刷完,压力山大,每天至少要8题,哎,我现在给自己定目标是5题,刷一半就好了。


说回本题,第一题就打击我了,我没认真看就以为是大数减价,立马开了个数组,做一个位运算,然后发现。。。他喵的原来只是考输出格式。


Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int a, b ,c, sum;
    scanf("%d %d", &a, &b);
    sum = a+b;
    c = abs(sum);
    if(c<1000)
        printf("%d", sum);
    else if(c>=1000 && c<1000000)
        printf("%d,%03d", sum/1000, c%1000);
    else
        printf("%d,%03d,%03d", sum/1000000, (c%1000000)/1000, (c%1000000)%1000);
    system("pause");
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值