1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.


Input


Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.


Output


For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.


Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 2 1.5 1 2.9 0 3.2


一开始用两个数组,然后傻傻地相加做,然后只有前三个测试点ac,百思不得其解,然后换一个思路,反正数据量不大,只有1000个,那我就只开一个1000的浮点型数组,下标作为指数,数组元素作为系数,一边输入一边相加。


两个数组没有全ac的1.0版本

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int aTNum, bTNum, cTNum;
    int i, j, w;
    scanf("%d", &aTNum);
    float a[aTNum][2];
    for(i=0, j=aTNum; i<j; i++)
    {
        scanf("%f %f", &a[i][0], &a[i][1]);
        if(a[i][0] == a[i-1][0])
        {
            a[i-1][1] += a[i][1];
            i = i-1;
            j--;
        }
    }
    aTNum = j;
    scanf("%d", &bTNum);
    float b[bTNum][2];
    for(i=0, j=bTNum; i<j; i++)
    {
        scanf("%f %f", &b[i][0], &b[i][1]);
        if(b[i][0] == b[i-1][0])
        {
            b[i-1][1] += b[i][1];
            i = i-1;
            j--;
        }
    }
    bTNum = j;
    cTNum = aTNum+bTNum;
    float c[cTNum][2];

    for(i=0, j=0, w=0; i<aTNum && j<bTNum; )
    {
        if(a[i][0] > b[j][0])
        {
            c[w][0] = a[i][0];
            c[w][1] = a[i][1];
            w++;
            i++;
        }
        else if(a[i][0] < b[j][0])
        {
            c[w][0] = b[j][0];
            c[w][1] = b[j][1];
            w++;
            j++;
        }
        else
        {
            c[w][0] = a[i][0];
            c[w][1] = a[i][1] + b[j][1];
            w++;
            i++;
            j++;
        }

    }
//printf("%f %f \n", b[i][0], b[i][1]);
//printf("\n");

    while(i<aTNum)
    {
        c[w][0] = a[i][0];
        c[w][1] = a[i][1];
        w++;
        i++;
    }
    while(j<bTNum)
    {
        c[w][0] = b[j][0];
        c[w][1] = b[j][1];
        w++;
        j++;
    }

    printf("%d", w);
    for(i=0; i<w; i++)
    {
        printf(" %.0f %.1f", c[i][0], c[i][1]);
    }
    return 0;
}

全ac版本

#include <stdio.h>
#include <stdlib.h>

int main()
{
    float a[1001] = {0};
    int num, expt, counter;
    float coef;
    int i;
    scanf("%d", &num);
    for(i=0; i<num; i++)
    {
        scanf("%d %f", &expt, &coef);
        a[expt] += coef;
    }
    scanf("%d", &num);
    for(i=0; i<num; i++)
    {
        scanf("%d %f", &expt, &coef);
        a[expt] += coef;
    }
    for(i=1000, counter=0; i>=0; i--)
    {
        if(a[i]!=0)
            counter++;
    }
    printf("%d", counter);
     for(i=1000; i>=0; i--)
    {
        if(a[i]!=0)
            printf(" %d %0.1f", i, a[i]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值