【PAT】1002. A+B for Polynomials (25)

题目描述:

This time, you are supposed to find A+B where A and B are two polynomials.

翻译:这一次,你应当去完成两个多项式A和B的相加了。

INPUT FORMAT

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

翻译:每一个输入文件包含一组测试数据。每一组测试数据包含两行,并且每一行包括一个多项式的信息:K N1 aN1 N2 aN2 … NK aNK,K是这个多项式非0的部分,Ni 和 aNi (i=1, 2, …, K)是各自的指数和系数。 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000。

OUTPUT FORMAT

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

翻译:对于每组测试数据你需要在一行内输出A和B的和,并且和输入格式一样。注意输出末尾不能有空格,请(系数)精确到1位小数。


Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5


Sample Output

3 2 1.5 1 2.9 0 3.2


解题思路:

注意:如果两个多项式其中一项相加为0是不能输出的,其他就没什么了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int K,Max=0,ccount=0;
double a[1010];
int N[25];
int main(){
    for(int i=0;i<2;i++){
        scanf("%d",&K);
        int n;
        double an;
        for(int j=0;j<K;j++){
            scanf("%d%lf",&n,&an);
            a[n]+=an;
            Max=max(Max,n);
        }   
    }
    for(int i=Max;i>=0;i--){
        if(a[i]){
            N[ccount++]=i;
        }
    }
    printf("%d",ccount);
    for(int i=0;i<ccount;i++){
        printf(" %d %.1lf",N[i],a[N[i]]);
    }
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值